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Introduction 

This manual provides a very comprehensive tutorial, by the end of which, you will be able to customize 
and go from opening and starting a new drawing to adding the finishing touches.  

We realize that you may not like the prospect of reading, but it is well worth your while to at least make 
yourself familiar with these very important tools that are at your fingertips.  

Since it would be impossible to cover every feature and aspect of 

CabMaster in this tutorial, our website provides access to… 

• the Application User Guide [F1] accessed from within your 
software. It includes FAQ’s which we are continually working on 
to give you helpful tips, tutorial videos and product information. 

• the online CM-Cabinets Library Users Guide which discusses 
drawing/job default options, library release notes and more.   

• Our Support Team. Simply click on the  

button and it will take you to a website where you can chat 

directly with a support technician during support hours. You can 
also access all your current and previous support tickets so you 
go back and review previous support discussions.  

• Community Forum where you can post and discuss topics with 
other CabMaster users. 

 

System Requirements 

For information use this link System Requirements (cabmastersoftware.com)  

 

Future Updates 

CabMaster Software has developed an advanced remote update feature, CabMaster AutoUpdater. If an 
update is available, you will be notified. A major application update is released officially about once a 
year with the latest library build. There are also regular updates for application and library builds, with 
requested cabinet options as well as fixes for reported bugs, are available either ‘on request’ or provided 
if the updates fix an issue that you have reported and software changes have been made to resolve.  

If at any time you want to be updated, all you need to do is to contact support via our website. 

When a new cabinet is added to the library in an update or if you have deleted a cabinet from your 
catalog, you can Add Missing Items/Cabinets to Catalog  (Follow the link to see how) 

 

Backups 

Full backups, in case of fire or theft, should be created on regular basis and taken offsite.  

Once you have set up your preferred defaults (materials, hardware etc) and prior to any subsequent 

installations or upgrade/update it is strongly recommended to create a backup.   

At the very least you can just make a copy of your whole CabMaster folder so that if there are any 
unexpected problems support can quickly trouble shoot. 

 

  

Customers must have a fully paid and valid Customer Care Agreement  in place to receive technical 
support and software updates. This is an annual renewal which must be purchased on a continuous 
basis. Please contact your sales representative for further information and pricing. 

https://documentation.cabmastersoftware.com/SystemRequirements.html
https://documentation.cabmastersoftware.com/AddingMissingCabinetsToCatalog.html
https://documentation.cabmastersoftware.com/Backup%20Libraries.html
https://appdocumentation.cabmastersoftware.com/support.html
https://appdocumentation.cabmastersoftware.com/support.html
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Installation 
Use this link for instructions on how to install your CabMaster™ product - Installing CabMaster  

If you have any questions or concerns, please do not hesitate to contact support. 

 

Important Concepts  
Before we start it is important that you understand that CabMaster™ deals with cabinet settings at three 
property levels.  

(1) Catalog Properties  

• global defaults for cabinet 
construction etc., set to reduce the 
need to make constant changes 

(2) Drawing Properties  

• each job has its own criteria, i.e. 
drawing defaults, which override 
the global defaults 

(3) Cabinet Properties  

• each cabinet can be customised and therefore override both global and drawing/job defaults 

 

 

 

To understand these concepts please follow the links [Ctrl + Click] to access the Online User Guides. 

• Catalog/Drawing Properties   

o This topic includes a video  for beginners with a general overview on how to setup. 

• Introduction to Properties  

o A property is a user-defined variable that every cabinet in the library can access and the 
end user can modify. 

• Cabinet Properties   

o Cabinet Property sheet provides the ability to customise individual cabinets. 

 

The Command Reference and the Frequently Asked Questions [FAQs] are also worth a look at. 

• No Catalog Message  

• No Images Message  

• No Palettes Message  

• File Options  [F10] - where you set Automatic Saves and other preferences. 

• File Locations  [F10] - where various components required by CabMasterPro™ are located. 

•  

Starter catalogs are included in the installation and with CabMasterPro™ and higher you can 
customise this or create a new catalog. This manual relates to the starter library.  

 

 

 

 

Panel Estimator  is available with Designer Pro and higher software but needs to be installed 
separately by support. 

As lessons are completed you can save these in the default folder called the ‘Data’. 

In the software, use the keyboard F10 key and select the File Locations page, to see where Data 
files and other files accessed by the application software are located.  

https://documentation.cabmastersoftware.com/Installing_CabMaster.html
https://documentation.cabmastersoftware.com/CatalogDrawingProperties.html
https://documentation.cabmastersoftware.com/PropertySheets.html
https://appdocumentation.cabmastersoftware.com/index23.html
https://appdocumentation.cabmastersoftware.com/index5.html
https://appdocumentation.cabmastersoftware.com/no-catalog-message.html
https://appdocumentation.cabmastersoftware.com/no-images-message.html
https://appdocumentation.cabmastersoftware.com/no-palettes-message.html
https://appdocumentation.cabmastersoftware.com/file-options.html
https://appdocumentation.cabmastersoftware.com/file-locations.html
https://appdocumentation.cabmastersoftware.com/panelestimator.html
https://appdocumentation.cabmastersoftware.com/panelestimator.html
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The aim of this tutorial is to teach you how to use CabMaster™, in as simple a way as possible. It is 

designed to get you up and running quickly and introduces you to many of the key CabMaster™ features. 
 

 

 

 

 

 

 

 

 

This Design Tutorial is set out as a number of lessons which begin with the creation of the design 
environment and setting up the walls.  

Through each lesson, we will look at the different features of CabMaster™ and how to put these into 
practice. You will also be provided with some user tips.  

By the time you complete the tutorial you will be able to customise and go from opening and starting a 
new drawing to adding the finishing touches, creating this kitchen design. 

3D View 

 

 

 

 

 

 

 

 

 

Plan View 

 

 

 

 

This tutorial was written using Designer Pro and you may find that some features in this 

tutorial are not available in Designer 3D or Designer CL, for example reporting. 
 

External links to online User Guides and Videos, indicated with an  icon, are 

provided to be used in conjunction with this tutorial.  

  Internal links are also included which you simply Ctrl + Click to follow.         

To return to where you were previously, use Alt + Left-arrow. 
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Starting CabMaster  
Open CabMaster by clicking once on the CabMaster™ desktop icon or from the ‘Start’, All Apps menu. 

A start screen  will be presented which allows you to… 

1. Select ‘Library to Use’ 

Select ‘CM-Cabinets’ Library from the drop list, as shown.  

This is important for the lessons to function correctly. 

CabMaster™ is based around the idea of a library which is a collection of pre-

built items that you use to construct your designs. 

You can only have one library loaded at a time, but you may change between 

libraries at any time.  

Most of the time you will want a library loaded when you start a new drawing, 

so you are given the option to select a library whenever you start CabMaster™. 

 

 

2. Click on the ‘Create a New Drawing’ button 

The drawing starts off with its own set of properties, called the Drawing Properties, which are an exact 

copy of those in the library. This means that the library properties are the default values, and 

these can be modified in the drawing 

properties for each individual drawing 

without changing the library.  

When you create a new drawing, you 

typically start with a library loaded, so 

that the new drawing will be based on 

selected library, which in this case is 

CM-Cabinets selected in step 1 above. 

The Drawing Properties, shown here, 

is presented (if not press F4 key). From 

the category tree select Job Setup 

and then select the Job Defaults page 

as shown, and ensure the Floor Cabinet 

default settings are...  

• Carcass Height is 730mm  

• Kick Height is 140mm  

* Bench height will therefore be the 730mm (Carcass) plus 140mm (Kick) = 870mm.  

• To save and close the dialog click OK. 

The Job Setup > Materials page for this tutorial, is set to use 18mm panel and door/drawer material. 

Now we will discuss the application interface that you will see when CabMaster™ is opened.  

CabMaster™ provides a central point in the form of Friendly Pages, also referred to as Property 

Sheets, that allow you to modify the properties of your drawings, an example is shown above.  

This is done through edit boxes with/without drop lists , checking boxes  and radio 

buttons .  

A typical use of no library loaded is when creating a template .  

A template is typically applied when starting a new drawing using the Create 
from template dialog. For these lessons it is not required and you can select 
whatever template is available or <none> i.e. no template selection. 

https://appdocumentation.cabmastersoftware.com/about.html
https://appdocumentation.cabmastersoftware.com/templates.html
https://appdocumentation.cabmastersoftware.com/templates.html
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CabMaster Interface 

Ribbons and Lesson Terms 

CabMaster™ uses a Ribbon toolbar which is designed to help you quickly find the commands that you 
need to complete a task which are organized in logical groups collected together under tabs.  

In these lessons, you will be required to select commands (e.g. Plan) located under the applicable 
tabs, (e.g. shown View tab). This will be referred to as View > Plan (illustrations will also be provided). 

 

 

 

 

 

 

 

Cabinet Selection  

When first opened, the Home  tab allows you to select cabinets from the current library. 

 

CabMaster™ offers a large selection of cabinets which can be filtered using the... 

1. 4 way Cabinet Selection  drop list which allows you to filter your cabinet selection by… 

• Library e.g. CM-Cabinets 

• Type e.g. Floor, Wall, Tall 

• Sub-Type e.g. Benchtop, Drawer, Sink 

• Cabinet e.g. Floor Corner Drawer 

2. Cabinet Picker  which displays a tree view, shown right, that corresponds to 

the drop list selections discussed above. 

• The command button is used to turn visibility of this ON or OFF. 

3. Palette / Cabinet Gallery  which displays images of cabinets available.  

• Filter selection by using the drop menu  

• You can also create your own custom palettes. 

 

In these lessons, we will be using the first option above i.e. 4 way Cabinet Selection drop lists. 

There is more than one way to perform an operation and this tutorial will include tips and extra 
notes which will discuss some of these. You can also add to the Quick Access  tools which sit above 
the Ribbon - for example Save, Undo/Redo - which are frequently used commands.  

Try clicking on the Context Help  button (see image below) and then click on a command.  

 

Note that the Drawing Properties can be opened using the command button shown far right. 

Alternatively, you can use the Keyboard Shortcut  F4 [See also Mouse Shortcuts  and Menus ] 

https://appdocumentation.cabmastersoftware.com/home.html
https://appdocumentation.cabmastersoftware.com/index23.html#cabinet-selection
https://appdocumentation.cabmastersoftware.com/cabinet-picker.html
https://appdocumentation.cabmastersoftware.com/cabinet-gallery.html
https://appdocumentation.cabmastersoftware.com/quick-access.html
https://appdocumentation.cabmastersoftware.com/quick-access.html
https://appdocumentation.cabmastersoftware.com/keyboard-shortcuts.html
https://appdocumentation.cabmastersoftware.com/keyboard-shortcuts.html
https://appdocumentation.cabmastersoftware.com/mouse-shortcuts.html
https://appdocumentation.cabmastersoftware.com/mouse-shortcuts.html
https://appdocumentation.cabmastersoftware.com/index3.html
https://appdocumentation.cabmastersoftware.com/index3.html
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Lesson 1: Adding Walls 

This lesson assumes that you have already started CabMaster™ as 
discussed in the previous topic and have set Drawing defaults. 

In this lesson, we are going to learn how to: 

▪ Draw Walls 

▪ Move Walls 

▪ Save your drawing 

 

Our First Drawing 

In this lesson, you will begin to discover the different tools available to help you with your drawing. 

In this lesson, we will use the Wall command icon located on the Insert  tab and then customising 

these walls using the Movement  commands.  

 

 

Once we have drawn the walls, we will learn about saving our drawings. 

  

There are a number of ways to place walls – see Wall Placement Tutorial  
 

The quickest way is to use your mouse to click and drag, as shown. 

• Click on the Insert > Wall command icon 

• Click on your start point and drag in direction and distance 

o Image shows start point bottom left and dragged 1850mm Up 

• Release the mouse button 

• Repeat until all walls added 

• To end, click on another command e.g. Select 

o To Start a New Wall, click on the Wall icon again. 
 

Note: The status bar  has a notification area (bottom left) that describes 

actions as these are performed which can be helpful.   ---------> 
 

There are a number of discussions in the Application User Guide that are a recommended read… 

• Wall Tool  used to customise the wall which can be done before or after placement. 

• Wall Reposition and Resizing tutorial  

• Wall Opening and Arches tutorial  

• Wall Sloped using Height tutorial  includes a video  

https://appdocumentation.cabmastersoftware.com/insert.html
https://appdocumentation.cabmastersoftware.com/movement.html
https://appdocumentation.cabmastersoftware.com/wall2.html
https://appdocumentation.cabmastersoftware.com/wall2.html
https://appdocumentation.cabmastersoftware.com/status-bar.html
https://appdocumentation.cabmastersoftware.com/status-bar.html
https://appdocumentation.cabmastersoftware.com/wall.html
https://appdocumentation.cabmastersoftware.com/wall.html
https://appdocumentation.cabmastersoftware.com/wall-move-resize.html
https://appdocumentation.cabmastersoftware.com/wall-move-resize.html
https://appdocumentation.cabmastersoftware.com/wall-opening-and-arches.html
https://appdocumentation.cabmastersoftware.com/wall-opening-and-arches.html
https://appdocumentation.cabmastersoftware.com/wall-sloped.html
https://appdocumentation.cabmastersoftware.com/wall-sloped.html
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Wall Placement using Movement commands 

In this lesson we will be creating the following wall… 

 

 

Step 1 

Select the Insert > Wall command  

• Click in the lower left corner of the drawing page to start the wall 
 

Step 2 - Wall Edge 1 

To draw left hand vertical wall proceeding upwards, use the Movement group commands for next steps… 

• In the Set Length edit box, type the distance of 2700mm 

• Click on the ‘Up’ arrow 
 

Step 3 – Wall Edge 2 

To draw a wall set at 45 degrees to this wall 

• In the Set Angle edit box, type in the angle of the 45 degrees 

• In the Set Length edit box, type in the distance of 1800mm 

• Click on Move At Angle icon to draw the wall at 45 degrees 

 

 

Grid on Plan  

Grid lines can be turned on/off. Simply tick View > Grid check box in the Show/Hide group, as 
shown above. Since you will usually want walls to be square, you may want to also turn on View > 

Snap to Grid. For more details see Grids and Snap Tutorial . 

Wall Direction 

Walls, Floors and Ceilings need to be drawn “one way” in a clockwise direction. In general, it is best 
to start in the lower left corner of the drawing page, leaving enough space to later insert dimension 
lines  etc. If you hold down the SHIFT key, the wall will be drawn automatically at increments of 
45deg to the starting point.  

 

 

If you want to go down and to the right at 45 degrees, 
you can either type in -45 or 315 to set angle. 

 

 

https://appdocumentation.cabmastersoftware.com/grids-and-snap.html
https://appdocumentation.cabmastersoftware.com/grids-and-snap.html
https://appdocumentation.cabmastersoftware.com/dimensions.html
https://appdocumentation.cabmastersoftware.com/dimensions.html
https://appdocumentation.cabmastersoftware.com/dimensions.html
https://appdocumentation.cabmastersoftware.com/dimensions.html
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Step 4 – Wall Edge 3 

To draw a horizontal wall, again use the Movement group commands for the next steps… 

• Click in the ‘Set Length’ box again, set the distance to 4500mm.  

• Click the ‘Right’ arrow 
 

 

 
 

Step 5 – Wall Edge 4 

To draw a vertical wall proceeding down… 

• Click in the ‘Set Length’ box again, set the distance to 3900mm. 

• Click the ‘Down’ arrow  
 

Step 6 – Wall Edge 5 

To draw a horizontal wall to the left of this wall… 

• Click in the ‘Set Length’ box again, set the distance to 2100mm. 

• Click the ‘Left’ arrow tool. 

Your drawing should now look like the illustration on the previous page. 

 

Moving Walls 

Once the wall has been placed it can be moved to a more suitable location on the drawing page. 

There are a number of ways to reposition and resize walls.  

The Wall Reposition and Resizing tutorial  discusses three (3) methods using the… 

1. Wall Properties 

2. Right click menu options Move Out and Change Length 

3. Object “handles” 

 

 

 

 

 

 

 

 

 

 
 

Save your drawing 

As this is the first time saving the current lesson, from the File menu, select the Save As command and 
provide a file name so that you can easily locate it later. The default folder for saved drawing is called 
‘Data’.  

Handles 

Handles are the small boxes that appear at the ends and mid-points of the walls.  
When a wall handle is selected, its small square is filled in. Handles not selected have open small 
squares. (NB: Dragging by the corner handles will alter the angle of the corner). 

The single handle, not connected to the wall can be used to move all walls at the same time.  

Select Tool  
When Select  is turned ON, it changes to the Select tool, which allows you to highlight objects by 
clicking on them individually or select multiple items by clicking on a blank area of the drawing near 

items for selection and dragging the mouse to form a box. Any objects inside or touching the box will 

become selected. This means that if you wish to move the walls plus any cabinets placed, then 
you simply run the cursor over the whole page i.e. click your mouse starting at the top left corner 
point and drag the cursor to the bottom right corner, therefore selecting all objects on the page. 

 

You will notice that after you click the ‘Right’ arrow, the Set Angle edit box is automatically 

readjusted to the direction just moved, and now shows 0 instead of 45. 

In the software, use the keyboard F10 key and select the File Locations page, to see where Data 
files and other files accessed by the application software are located.  

 

https://appdocumentation.cabmastersoftware.com/wall-move-resize.html
https://appdocumentation.cabmastersoftware.com/select.html
https://appdocumentation.cabmastersoftware.com/select.html


CabMaster Getting Started Guide                                                            Lesson 2: Cabinet Placement 

14 | P a g e  

 

Lesson 2: Cabinet Placement 
In this lesson, we are going to learn how to… 

▪ Place cabinets 

▪ Format cabinets 

▪ Add End Panels 

▪ Introduce the Revert feature 

 

Cabinet Selection 

As discussed in the introductory section on Cabinet Selection, CabMaster™ offers a large selection of 
cabinets which can be filtered. In this lesson, we will use the 4-way drop list and the first cabinet that 
we are going to place is a ‘Floor Angled’ cabinet: 
 

Step 1 

Since we will be using mostly floor cabinets, filter 

your list by Type using drop list and select ‘Floor’.  
 

Step 2 

Using the Cabinet drop list, select ‘Floor Angled’. 
 

Step 3 

In the middle of the page, click and hold down the left mouse button. 

▪ The ‘Floor Angled’ cabinet should be presented on 
the page  

▪ While holding down left mouse button, move 
your mouse to the top, right hand corner of the 
drawing i.e. placing the cabinet in the corner as 

shown → 

o If ‘Auto Align’ is switched ON by using the 
keyboard shortcut A (which toggles the 
alignment On/Off) or the right click menu 
shown, the cabinet will try to rotate to align with the angle 
of a nearby wall. 

o You can also rotate with the – or + keys 

▪ Release the mouse button. 

Note that the Floor Angled cabinet shows the direction of door swing. We 

will discuss this later in this section.  

Open the Lesson 1 in the ‘Data’ folder and you may want to save as Lesson 2 so if anything goes 
wrong with this lesson, you can don’t have to start from scratch. 

Rotating Cabinets – Single or Multiple Selection 

< > keys   or    + - keys 

Press the left and right ‘angle’ bracket keys (also comma and full stop) as well as the plus and minus 
keys to rotate the current selection. 

These keys rotate either by 15° intervals without shift or by 90° intervals if the ‘Shift’ key if pressed. 
– key rotates right and the + key rotates to the left. 

Hold down the ‘Ctrl’ key to nudge the angle in 1° steps (for + and - keys) or ‘Ctrl’ + ‘Shift’ keys 

for smaller 0.1° steps. (Useful with Curved Cabinets) 
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If you have difficulty placing cabinet near to Wall, turn on View > Snap to Handle  

CabMaster™ is designed to automatically detect the environment that surrounds the cabinet so that 
when placed, it is in the correct position.  

It takes practice to become efficient with this feature. At times, you will need to move the mouse beyond 
the wall for the cabinet to rotate. Do not be alarmed if this occurs, as CabMaster™ is designed to ensure 
that the cabinet positioning is correct before it rotates. 
 

Customise a Cabinet/Item Before Placement 

Cabinets can be customised before or after they are placed – see Format Cabinet/Item  

As we are going to place an interior door to the left of this cabinet (in Lesson 10), we will 
need to seal the left end with a Floor End Panel. Before placing it on our drawing page, 
however, we want to customise this panel as we need to remove its benchtop and 

kickboard sections, as shown right. 

Step 1 

From the cabinet drop list, select ‘Floor End Panel’ 
 

Step 2 

Double click the ‘Cabinet Tool’ button to open 
the tool dialog window. Note… 

• the background colour of the window 

presented is light blue;  

• the title bar includes the word ‘Tool’;  

• as this is a panel, not a cabinet, the category tree 
heading is Panel Details. 
 

Step 3 

To remove Kickboard, select Panel Details > 
Kickboards page and untick ‘Kick’. 
 

Step 4 

To remove Benchtop, select Panel Details > Benchtop 
page and untick ‘Include Benchtop’ 
 

Step 5 

Now we want to place an End Panel from Floor height.  

Select Panel Details > General page and tick ‘Extend 
to Floor’ (ensure that ‘Off Floor’ = 0mm) 

• You can change the dimensions of a panel in 

General page but to access the ‘Depth’ edit box 
you will need to untick the ‘Flush with Doors’ 
option - blue arrow shown → 

 

Step 6 

Now we will place the End Panel next to the Floor Angled cabinet we 
previously place. 

  

If you have problems with placement, you may need to turn Off 

Detect Collisions using the right click cabinet menu. 

It is recommended that you only customise cabinets before placement. 

https://appdocumentation.cabmastersoftware.com/grids-and-snap.html#snap-to-handle
https://appdocumentation.cabmastersoftware.com/format-cabinet.html
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With the Cabinet Tool button still selected for the ‘Floor End Panel’… 

• In the middle of the page, click and hold down the left mouse 
button.  

▪ The ‘Floor End Panel’ should be presented on the page. 

▪ While holding down left mouse button, move your mouse 
to the top, left hand section of the placed cabinet as shown → 

Remember to place ‘Floor End Panel’ against the right side of the 
cabinet and inside the overhang.  

 

Door Swing and Cabinet ID on Plan 

Note that the image of the Floor Angled cabinet above 

does not show the direction that the door swings open. 
This is because it has been turned off in the Drawing 
Properties [F4] on the Display > Options page →  

There is also an option to Show Cabinet ID which is 
turned on above and refers to the number in brackets 
after the Cabinet Label i.e. (1) and (2) – see FAQ Hiding Cabinet Labels   

 

Customise a Cabinet After Placement 

Now we will discuss customising the cabinet after it has been placed. 

As there is a door way to the left of this cabinet, we will need to seal the left end. 

Step 1 

Click on the ‘Select’ icon to turn on the command function.  
 

Step 2 

Right click on the Floor Angled cabinet previously placed and 
select ‘Format…’ option from the presented menu. 
 

 

 
 

Step 3 

As there is a door to the left of this cabinet, the left end will need 

to be sealed, as shown, but not the right.  

The image in the Preview Pane will 
initially only show the Kick and Kick 
Face in the Front.  

From the Properties inspector category 
tree, select Cabinet Details > 
Kickboards page. 

Tick the Left Seal and leave the Recess 
at 0mm, as shown. 

 Double clicking on cabinet will also allow you to format. 

For a better view to enable accurate placement Zoom In. There are a number of ways to do this… 

• Quickest way is to use the mouse wheel; 

• Use the command icons on the View tab; 

• Use the Status Bar (bottom right slider); 

• For more ways see discussion Zoom (cabmastersoftware.com)  

https://appdocumentation.cabmastersoftware.com/hiding-cabinet-labels.html
https://appdocumentation.cabmastersoftware.com/zoom.html
https://appdocumentation.cabmastersoftware.com/zoom.html
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Step 4 

Now we want to give the Benchtop an overhang to 
sit over the End Panel previously placed on the left.  

Select the Cabinet Details > Benchtop page… 

• Tick the ‘Left’ check box to seal the left end; 

• Type in 50 to give it an overhang of 50mm.  

 

Shelves and Shelf Heights 

On the Cabinet Details > Options page you can select from 0-5 shelves and make them either Fixed 
or Adjustable. There are also four (4) styles of shelves available. (To view each Style, change the Preview 
to either Ortho or 3D Wireframe and watch what happens as you change the Style selection.) 

On the Labour & Construction > Shelves page you can further customise the position of shelves. 
 

Typically, shelves are automatically spaced inside 

a carcass for the whole drawing using the Drawing 
Properties [F4] →.  

The Shelves page, as shown, determines whether 
or not shelves are adjustable and can be amended 
for Standard, Angled and Corner cabinets. (See 
Construction Shelves in the Library User Guide ) 

The quantity is calculated based on the minimum 
gap between shelves for Floor, Wall and Tall 

cabinets independently. By doing this the number 
of shelves increases as the cabinet gets taller. 

 

 

 

 

 

Revert Feature 

Revert allows you to reload the current drawing 

from the last saved point.  

This command is useful when you add or move 

cabinets around to see how it looks. If you are 
not happy with the changes you simply click 
select ‘Revert’ from the File menu. The 
drawing will then revert to how it was the last 
time you saved it to file.  

 

On completion of each lesson, it is recommended to save your drawing. 

 

 For more on adjusting ‘Shelf Heights’ see the topic on Shelf Heights and Cutouts  in the online 

CM-Cabinets Library User Guide. 

 Whether the Kick and/or Kick Face are included in your current job can be controlled in the 

Drawing Properties [F4] on the Materials-Advanced > General Options  page.  

The Reset button will reset the cabinet options back to the settings in the Drawing Properties. 

Warning: If you create a drawing and have not saved it prior to ‘Revert’, you will lose the unsaved 
drawing. 

 

https://appdocumentation.cabmastersoftware.com/preview-pane.html
https://appdocumentation.cabmastersoftware.com/preview-pane.html
https://documentation.cabmastersoftware.com/ShelvesPage.html
https://documentation.cabmastersoftware.com/ShelfHeightCutouts.html
https://documentation.cabmastersoftware.com/ShelfHeightCutouts.html
https://documentation.cabmastersoftware.com/MaterialsAdvanced.html#Include
https://documentation.cabmastersoftware.com/MaterialsAdvanced.html#Include
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Lesson 3: Placing Cabinets 
In this lesson, we are going to introduce additional cabinet to the drawing. We 

are also going to start to develop skills that will enable you to alter the 
dimensions of the cabinets that you introduce. 

If you saved and closed the previous lesson, you can use the Open an Existing 
Drawing (and select the required drawing) or Open Most Recent drawing. 

 

Placing Floor Drawer Cabinets 

We will now add two drawer cabinets to the drawing and format one of these before placement. 
 

Drawer 600mm Cabinet 

Step 1 

To tighten the Filter selection, we selected Type: Floor and a 
Sub-Type: Drawer.  

Then from the shorter drop list, selected the ‘Floor 3 Drawer’.  

 

Step 2  

Place the first ‘Floor 3 Drawer’ 600mm (which is the default width)  

• Click and hold the left mouse button in the middle of the room and;  

• Drag to the right of the Floor Angled cabinet already on the drawing  

 

Drawer 650mm Cabinet 

We are now going to place another ‘Floor 3 Drawer’ but before placement we 
will change the width to 650mm.  

Step 1 

As the ‘Floor 3 Drawer’ is already selected, double click on the Cabinet Tool  

On the Cabinet Details > General Settings page… 

• edit the width of the drawer cabinet from 

600mm to 650mm → 

Remember formulas can be used in edit boxes e.g. 

 

Note that the Quantity of drawers can be changed but 

the cabinet label* on the plan will not change i.e. it will 
remain in this instance as Floor 3 Drawer. 
 

Step 2 

Place amended cabinet on the right of ‘Floor 3 Drawer 600’ in same way as discussed in Step 2.  

 

 

 

  

 The cabinets should automatically rotate but remember you can use the + or – keys.  

* The Label display can be customised by using View Options [F9] on the View tab                               
or double clicking on the drawing page – see Cabinet Label Display Tutorial.  

We will learn how to insert a dimension line to a drawing in Lesson 7. 

 You can also simply type the required cabinet name i.e. Floor 3 Drawer (no filters required),  

      or typing in the letter F (or a combination) will find the first instance of manually entered text. 

https://appdocumentation.cabmastersoftware.com/view.html
https://appdocumentation.cabmastersoftware.com/view.html
https://appdocumentation.cabmastersoftware.com/drawing-label-display.html
https://appdocumentation.cabmastersoftware.com/drawing-label-display.html
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Placing a Floor Corner Cabinet 

It is important that you understand how corner cabinets are constructed within CabMaster™ so that you 
can modify them correctly.  

A Corner cabinet’s left and right sides are referred to as the Main and Extension. There are different 
‘join’ options available when creating corner cabinets e.g. mitred or square to longest. By understanding 
the Main and Extension concept you will be able to change characteristics and get the correct result. 

 

Step 1 

Select the ‘Floor Corner’ cabinet and double click on 
the Cabinet Tool button. 
 

Step 2 

Select Cabinet Details > General Settings page 

• In the Main Width edit box change the dimension from 
900 to 1350mm 

• The Extn edit box will be greyed out, so you need to tick 
the Extn check box. Now you can… 

▪ change the Width of the Extn to 900mm 

• Now we want to have 2 doors on the Main and 

only 1 door on the Extension. To do this… 

▪ from the Quantity drop list select 2X1 
and view the result in the Preview → 

  

Step 3 

Close the ‘Cabinet Tool’  
 

Step 4 

Place cabinet in the lower right corner of the room with the 1350mm main side 
pointing to the top of the screen, as shown →. 

 

Deleting Cabinets 

To delete one or more cabinets, first select the cabinet/s and then either use 
Delete on your keyboard or use the right click menu and select the Clear option. 

 

You have completed this lesson so you may want to Save your drawing. 

 Here we have turned on the Display > Door Swing option in the Drawing 
Properties [F4] but if you want to see the door opened in the Preview and in 
3D Display, use the Doors slider on the Cabinet Details > Options page. 

                               

 The dimension lines for the Main show 1334.0 + 16.0 = 1350mm where the 
16mm is the Gap Between Cabinet and Wall set on the Cabinet Details > 
Options page. 

 

 

See also: CM-Cabinets User Guide on Cabinet Design > Construction > Corner Cabinets  

https://documentation.cabmastersoftware.com/CornerCabinets.html
https://documentation.cabmastersoftware.com/CornerCabinets.html
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Extra Notes - Standard Cabinets 

Splayed Ends page 

Options to Splay Ends are available on the Cabinet Details > Splay page for Floor, Tall and Wall 
Standard cabinets, as shown below. This can be turned on/off for either or both ends. 

To splay the ends means to have them at an angle, making the front and back of the cabinet different 
widths. The example shows the Right End set an angle of 22 degrees. 

It is also possible to add Front Panels (which can be oversized for scribing) to space the doors away 

from the adjoining cabinet or wall. You can also add mullions on which to hang the doors. 

 

 

Floor Division 

There is an option to Remove Physical Door making Divisions possible, allowing for an ‘open’ cabinet. 
You can also remove handles, make glass and bifold doors. 

 

 Default Materials are set in the Drawing Properties [F4]  See also: Independent Hinging  

https://documentation.cabmastersoftware.com/cabinet_independent_hinging.html
https://documentation.cabmastersoftware.com/cabinet_independent_hinging.html
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Lesson 4: Auto Cutback Feature 
In this lesson, we are going to introduce you to these new features… 

▪ Auto Cutback 

▪ Zoom Box 

▪ New cabinet from the ‘Tall’ category 
 

The Zoom Box  

The View > Zoom Box command button allows you to highlight the area of the 
drawing to zoom in. 

In this lesson, it will allow us to zoom in on the space between the ‘Floor Drawer 
650’ and ‘Floor Corner 1350’ so that we can see this area more clearly. This can 

make cabinet placement a lot easier, especially when we are using some of the 

advanced tools. 
 

The Auto Cutback Feature 

This is a unique feature to CabMaster™ which automatically resizes a larger cabinet to fit perfectly in 

between two existing cabinets. It also updates any component or cutting information for the modified 
cabinet. 
 

Place Cabinet Between Two Existing Cabinets 

Step 1 

Select View > Zoom Box from the Zoom group (shown above).  

Then move the mouse starting from the ‘Floor Drawer 650’ and ending 

with the ‘Floor Corner 1350’, as shown… 

• You will notice that as the mouse hovers over the drawing page, a 
magnifying glass appears; 

• Move the magnifying glass to the location that you wish to start 
from (shown top left). 

• Click and hold down the left mouse button. Drag to draw a box 
around the area that you want to zoom in on.  

When you release the mouse key, the drawing image will have increased 
dramatically to show you the selected area. 
 

Step 2 

Now we want to place a cabinet in this vacant area, which is only 400mm.  

Select a cabinet that is like the one you need regardless of the 

size.  

For this lesson, select a ‘Floor 1 Door Left’ which has a default 
width of 450mm. (Shown using Tape Measure) 
 

Step 3 

To use this ‘Auto Cutback’ feature…  

1. Place the cabinet and while holding down the left mouse 
button and the ‘Ctrl’ key, move the cabinet on the 
drawing page into the vacant area, shown →.  

 Do NOT let go of the left mouse button yet. 

https://appdocumentation.cabmastersoftware.com/draw-coordinates.html
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2. With the left mouse button and ‘Ctrl’ key still engaged, drag the cabinet into the vacant area 

until it is against the wall but still overlapping the cabinet beside it (overlap shown above). 

3. Release the mouse button and the cabinet will shrink to 
fit exactly into the available space → 

4. Finally, release the ‘Ctrl’ key. 

The program cuts the cabinet back to the available size which 
in this example is 400mm. 

 

 

 

 

 

 

 

 

 

 

 

 

Adding Tall Cabinets 

Adding Tall cabinets is the same as adding Floor units.  

In this example, we are going to be placing a ‘Tall 2 Door’ cabinet beside 
an existing floor unit. Therefore, we are going to have exposed ends that 

needs to be covered by an ‘End Panel’ with kick and another to floor.  

Step 1 

Select the ‘Tall End Panel’ and place next to the ‘Floor Corner’. (This end panel has a kickboard). 
 

Step 2 

Select a ‘Tall 2 Door’ (which should have a default 
width of 900mm) and place this cabinet next to the 
‘Tall End Panel’ place previously. 

 

Step 3 

Select a ‘Tall End Panel to Floor’ and place beside 
the exposed end of the ‘Tall 2 Door’ 

Your drawing should now look like the image → 

 

 

You have completed this lesson.  

Auto Cutback Summary 

1. Hold down both the ‘Ctrl’ key and the left mouse button while dragging into place. 

2. Line up one side of the cabinet with the cabinet beside it. 

3. Release the mouse button and then the ‘Ctrl’ key. 

 See Keyboard Shortcuts  for more on keys that can be used while dragging. 

 

Reset View 

To return to the normal ‘Full Page’ view (i.e. exit Zoom), right click on the drawing                                
page and from the presented menu (shown right) click on the Reset View option. 

CabMaster™ contains all the End Panels and Fillers that you will need to complement the cabinets. 

 

Shelves and Drawers can be added and recessed – 

see Cabinet Design topic on Tall Standard Fixed 

Shelf Recess  and Tall Standard Adding Drawers  

https://appdocumentation.cabmastersoftware.com/keyboard-shortcuts.html#drag
https://appdocumentation.cabmastersoftware.com/keyboard-shortcuts.html#drag
https://documentation.cabmastersoftware.com/TallStandardFixedShelfRecess.html
https://documentation.cabmastersoftware.com/TallStandardFixedShelfRecess.html
https://documentation.cabmastersoftware.com/TallStandardFixedShelfRecess.html
https://documentation.cabmastersoftware.com/TallStandardFixedShelfRecess.html
https://documentation.cabmastersoftware.com/TallStdDrws.html
https://documentation.cabmastersoftware.com/TallStdDrws.html
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Lesson 5: Views and 3D Environment 
In this lesson, we are going to introduce you to… 

• the 3D environment, including the various types of 3D views.  

• split views i.e. view multiple screens on a single page. 

 

View Types 

A number of View Types which can be accessed from the View tab  
or by using the buttons in the Status Bar . These are… 
 

Plan View 

This view displays a top-down plan of the current drawing. 

Extra tabs (Plan Tools) are made available allowing you to add 
Elevations  and Cameras .to the same plan page.  
 

Elevation View 

Generates an elevation of cabinets along each wall, accessed using tabs above the Status Bar.  

Elevations can also be placed on your plan and we will show you how in Lesson 7. 

 

List View 

This provides a listing of all the items currently on the drawing, without any visual representation. 

Cabinets and other items such as pricing, freight etc can be added for reporting information. 

For more details on List View  see the Application User Guide under Window Basics.  
 

Machining View 

Machining Tools are provided to integrate EzyNest/EnRoute directly into CabMaster Pro or higher 
software products – See Application User Guide on Machining  

Extra tabs are made available allowing you to Export Machining for… 

• Current Drawing  – generates on batch of part files (DXF) for each material used in current 
drawing. 

• Combined  – lets you combine multiple little batches of components (parts) and nest them to 
prepare one combined job. It also allows you to create a job that has repeats of the current job. 

 

3D Views  

Changes the display mode of the active pane to a three-dimensional rendered view of the drawing and 
the 3D Tools on the Display tab  becomes available. See the tutorial on Generating A 3D Image  

  

In the previous lessons we added cabinets to Wall Edge 4, so try it out! 

 

https://appdocumentation.cabmastersoftware.com/view.html
https://appdocumentation.cabmastersoftware.com/status-bar.html
https://appdocumentation.cabmastersoftware.com/elevations.html
https://appdocumentation.cabmastersoftware.com/cameras.html
https://appdocumentation.cabmastersoftware.com/list-view.html
https://appdocumentation.cabmastersoftware.com/index22.html
https://appdocumentation.cabmastersoftware.com/machining-view-current.html
https://appdocumentation.cabmastersoftware.com/machining-view-combined.html
https://appdocumentation.cabmastersoftware.com/display.html
https://appdocumentation.cabmastersoftware.com/generating-a-3d-image.html
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3D Environment 

In the 3D environment, you have four Render Modes which can be changed by using Display tab 
command icons or by right clicking on the page and using the menu, as shown. These are… 

 

Wireframe 

In the wireframe mode, lines are drawn 
representing the bounding edges of solid 
sections. There is no attention paid to 

hidden edges, which means you can 
clearly see inside the cabinet and right 
through cabinets to even see the wall 
behind it. Useful for checking that the 
internals of a cabinet e.g. shelf styles, 

look correct and therefore recommended 
to use when first generating a 3D image. 
 

Hidden 

This mode is almost the same as 
‘Wireframe’, except with the addition of 
‘hidden line removal’. After calculating 
the wireframe image, it determines 

which lines would be hidden from the 
current viewpoint and removes them. 

 

Solid 

This mode is more realistic than both wireframe and hidden because of the addition of coloured faces. 
Each surface on an object, such as a cabinet, is filled with a single flat colour. Solid views give a good 

estimate of colour without using textures.  
 

Textured 

This mode is almost the same as ‘Solid’ except with textures 
added. The bitmaps are applied to the appropriate faces, 
giving them a very realistic look.  

  

 

Materials 

Default materials for the current drawing are 
set on the Job Setup > Materials page of 
the Drawing Properties [F4].  

Materials can be changed on individual 
cabinets in the Materials category. 

See relevant discussions in the CM-Cabinets 

User Guide  and watch the video.  

For more information see topics on 3D Menu  and 3D Effects menu  options. 

 

As shown here, doors and drawers can be viewed in an open 
position in 3D by using the settings in the Drawing Properties 
[F4] on the Display > Options page (for the whole drawing) 
or the Cabinet Details > Options page of individual cabinets, 

in all Render Modes (shown here in Textured). 

Note that Panel and Door/Drawer 

material is 18mm which will affect 
measurements later in this tutorial. 

https://documentation.cabmastersoftware.com/MaterialsOverview.html
https://documentation.cabmastersoftware.com/MaterialsOverview.html
https://appdocumentation.cabmastersoftware.com/3D-menu.html
https://appdocumentation.cabmastersoftware.com/3D-menu.html
https://appdocumentation.cabmastersoftware.com/3D-effects.html
https://appdocumentation.cabmastersoftware.com/3D-effects.html
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3D Navigation 

The easiest way to reposition your 3D View is to use mouse shortcuts  
but you can also use the 3D Navigate menu  options, shown here. 
 

Mouse Shortcuts  

Rotate  Click and drag 

Pan  Shift + Left Click and drag  

or depress both left and right mouse buttons and drag. 

Zoom Ctrl + Left Click and drag 

or right click and drag or use the mouse wheel 

Reset Click the middle of mouse wheel. 

Select  Ctrl + Right click to select item and get a menu which allows you to Move 3D or to Format. 

 Move 3D moves items cabinets a precise distance in 3D space including Fwd/Back.  

 

 Format allows you to edit item properties. Here we have opened drawers. 

 

 

 

Export 3D and PDF 

Export 3D  is a full export of 3DS models which can be then viewed 
in Photoview  high quality ray tracer (and other 3D environments). 
You can also export to Google (Collada) format for use in Google 
sketchup. 

This is accessed from the File menu. Select Export > 3D Export →  

You can also export your completed drawing to create a pdf, which 
can then be sent and viewed at all angles by the customer. (See Export 
PDF tutorial )  
 

 

  

https://appdocumentation.cabmastersoftware.com/mouse-shortcuts.html
https://appdocumentation.cabmastersoftware.com/3D-navigate.html
https://appdocumentation.cabmastersoftware.com/move-3d.html
https://appdocumentation.cabmastersoftware.com/file.html#export-3D
https://appdocumentation.cabmastersoftware.com/3D-photoview-best-practice.html
https://appdocumentation.cabmastersoftware.com/export-pdf.html
https://appdocumentation.cabmastersoftware.com/export-pdf.html
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Split View - Multiple Views on a Single Page  

CabMaster has a feature that allows you to work in ‘Plan View’ while still being able to see the effect in 
3D view. To do this you need to split the screen.  

 

**Watch what the mouse does as you try the following… 

Step 1 

Change your drawing back to ‘Plan View’. 

▪ View > Split View in the Window group → 

or 

▪ Right click on a blank area of your drawing, which will 
bring up a menu and click on the ‘Split’ option  

Either option will bring up a cross hair as shown.  
 

**Do not click your mouse button at this stage 

Step 2 

If you move your mouse to the far left-hand side of the 
application window, you will notice that the four (4) panes can be 

cut down to two (2) viewing areas… 

▪ One pane on top 

▪ One pane on the bottom 
 

Step 3 

If you move your mouse back to the centre and move it 

vertically to the top of the application window, the four (4) 
panes can be cut down to two (2) viewing areas but this time… 

▪ One pane to the left 

▪ One pane to the right 

 

Active Panes 

The example shows four (4) panes, each pane with a different view 
in even sized panes. To resize the panes hover over the relevant 

splitter bar and you will see this  which allows you to drag to 
resize or to exit the Split view by dragging the splitter bar off the page. 

The commands on the View tab will affect 
only the Active pane.  

Commands on the other tabs will affect the 

whole document i.e. all panes. For example, 
if you insert a cabinet, the cabinet will be 
added to drawing in every available pane.  

  

Splitting panes can be useful especially if you want to use 2 monitors and have different view on 
each. Simply stretch the app across 2 screens and split – see Split Across 2 Monitors Tutorial  

For a complete discussion see Split Panes Tutorial (cabmastersoftware.com)  

You can only work in one Active pane at a 
time. To make a Pane Active click on the 

relevant page. 

mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro%20v8/CabMasterPro.chm::/command-reference/ribbons/view.html
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro%20v8/CabMasterPro.chm::/command-reference/ribbons/insert.html
https://appdocumentation.cabmastersoftware.com/split-across-2-monitors.html
https://appdocumentation.cabmastersoftware.com/split-across-2-monitors.html
https://appdocumentation.cabmastersoftware.com/panes.html
https://appdocumentation.cabmastersoftware.com/panes.html
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Camera View 

Camera view provides a way to store multiple camera view positions and allows you to easily place 3D 
Views onto a Plan View page. The camera view items placed are dynamically updated when the 
drawing changes. You can also rapidly switch between a number of “good” views. 

In this example, we have created a camera view and placed a 3D view of three cabinets onto the plan.  

As shown, one of these cabinets has then been selected and moved. As the cabinet is moved on the 

plan, the action is dynamically reflected in the placed camera view.  

 

 

 

Callouts 

Callouts allow you to create a zoomed and cropped portion of a view. They can also include dimensions 

and notations for a greater level of detail and can be used per drawing. 

The main types of Callouts are (1) Plan Callout, (2) Elevation Callout, (3) 3D Callout as per above. 

 

Plan Callout                                                 Elevation Callouts              

 

You have completed this lesson. 

For instructions on how to do this, see the Camera View Tutorial  in the Application User Guide. 

This is view is also called a 3D Callout. 

For instructions on how to create these, see the Callouts Tutorial  in the Application User Guide. 

https://appdocumentation.cabmastersoftware.com/camera-view-items.html
https://appdocumentation.cabmastersoftware.com/camera-view-items.html
https://appdocumentation.cabmastersoftware.com/callouts2.html
https://appdocumentation.cabmastersoftware.com/callouts2.html
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Lesson 6: Adding Wall Cabinets 
In this lesson, we will… 

▪ Commence adding in some Wall Cabinets 

▪ Add Glass doors and introduce DoorMaster LT 

▪ Introduce ‘Select into Tool’ which duplicates a customised cabinet. 

▪ Introduce ‘Tape Measure’ tool 

▪ Modify a cabinets width by dragging to size 
 

Adding Wall Cabinets 

We will now be adding some wall cabinets, as shown → 

 

Step 1 

Select ‘Wall Angled’ from the drop list and 
place above the ‘Floor Angled’ cabinet. 

 

Step 2 

Since there is a doorway located to the left of the ‘Floor Angled’ 
cabinet, we have an exposed end that needs to be sealed. 

Select ‘Wall Open Left’ and customise using the Cabinet 
Tool. 

• On the Cabinet Details > General Settings page 

• Edit width from 400mm to 300mm. 

• Place to the left of the Wall Angled. 

Step 3 

Select ‘Wall 1 Door Right’ and again customise using the Cabinet Tool. 

• Change width from 400mm to 450mm  

• Place to right of ‘Wall Angled’ cabinet. 

 

Glass Doors 

We are now going to customise and place a ‘Wall 2 
Door’ cabinet with two glass doors, to the right of ‘Wall 
1 Door’ as shown above. 

On the Cabinet Details > General Settings page… 

• Ensure Width is 900mm 

• Ensure Doors Quantity is 2 

• Tick ‘Make Glass Door’ check box 

• Place to right of ‘Wall 1 Door Right’ cabinet 

See Drawing Properties [F4] Materials-Advanced > 
Door Options page for Glass design etc. 

Maximise your view area by using your mouse wheel or Zoom 

command.  

Remember, that you may need to turn Align on and you can use 
the + or – keys to rotate if necessary. 

 

https://documentation.cabmastersoftware.com/MaterialsAdvanced.html#DoorOptions
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Using Select into Tool 

The ‘Select into Tool’ option is used when you have formatted a cabinet in the drawing and want to 

place another cabinet with the same characteristics.   

 

Now we will place another ’Wall 1 Door Right’ to right of ‘Wall 2 Door’ just created as illustrated below.  

Step 1 

With the ‘Select’ tool activated, left click on the ‘Wall 1 
Door Right’ previously placed, to select. 

NB: Handles will appear around the cabinet. 
 

Step 2 

Select ‘Select into Tool’ option from presented menu. 

This will automatically recreate the cabinet ready for you to 
place. 
 

Step 3 

Click to select the ‘Cabinet Tool’  
 

Step 4 

Left click anywhere on page and, holding down the left 
mouse key, place cabinet to right of ‘Wall 2 Door’ as shown. 

 

 

 

 

 

 

 

 

  

Select Into Tool Summary 

When you (1) ‘Select into Tool’ (2) click to select the ‘Cabinet Tool’ and (3) place on the drawing, 
you get a clone of the cabinet you selected into. 

Another thing you can do is double click on the cabinet tool, after ‘Select into Tool’ to see it there. 

 Selecting ‘Select into Tool’ does not change the property sheets to point to the tool. They continue 
to point to the currently selected cabinet. 

 

Split Cabinet and Make Even  

Single cabinets can be ‘Split’ into two similar cabinets at half width. Multiple cabinets can be selected 
and made into even measurements for each door using the ‘Make Even’ right click menu command. 
For instructions on how to do this see the Make Even and Split Tutorial  in the Online User Guide. 

DoorMaster LT 

A range of Door Profiles have been added into CabMaster™ for both display and machining purposes, 

if you have CabMaster Premium software. 

Glass 3D and machining is supported in all DoorMaster LT doors that have a frame of some sorts. 

For more on DoorMaster LT Licensing  and Glass Profiles  follow the links. 

If you have placed other cabinets in between the customisation of a cabinet, the changes will be lost. 

 Keyboard Shortcut Ctrl + D also creates another copy of the selected item. 

https://appdocumentation.cabmastersoftware.com/make-even.html
https://appdocumentation.cabmastersoftware.com/make-even.html
https://documentation.cabmastersoftware.com/DMLT_License.html
https://documentation.cabmastersoftware.com/DMLT_License.html
https://documentation.cabmastersoftware.com/Glass.html
https://documentation.cabmastersoftware.com/Glass.html
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Using Tape Measure 

 

Step 1 

Select a ‘Wall Blind Return Right’ cabinet and customise using 

the Cabinet Tool. On the Cabinet Details > General Setting page…  

• Edit the width from the default 700 to 1200mm 

• Edit the Doors Quantity from 1 to 2 doors 

• Place in the bottom right corner of wall, as illustrated. 
 

Step 2 

Since we are not sure of the distance between the ‘Wall 1 Door’ and the 
‘Wall Blind Return Right’, we may want to measure this distance before 
we choose the cabinet.  

On the Annotate tab, click on the Tape Measure command icon. 

• Ensure that World Measurement is selected in the Draw 
Coordinates group. 

 

• Start by hovering over the left edge of the ‘Wall 1 Door’ and hold 
down the left mouse button; 

• Without releasing mouse button, drag the cursor down to end point 
i.e. the edge of the ‘Wall Blind Return Right’ 

You should now be able to see the distance in mm from one cabinet to the 

other, as shown right. 

  

The Tape Measure command icon  is on both the Insert tab and the Annotate tab. 

The Tape Measure allows you to measure the distance from one point to another. This can be useful 
when we have to add a cabinet between two objects and need the exact gap measurement.  

 

 See Annotate > Tape Measure  as it is important to understand how the measurement is 
dependent on Draw Coordinates i.e. World or Page. 

Snapping:  The end points of the line are affected by snapping if                                                   
you have ‘Snap To Grid’ or ‘Snap To Handle’ enabled.        

‘Snap to Handle’ can also be used in conjunction with the Handles                                                                 
drop list to make selection of specific items simpler and accurate.                                                    
Typically, Handles should be set to <none> unless required, as in                                                      

Step 4 discussed on the next page. 

Movement Tools: When you release the mouse button at the second point, the distance and angle 
between the two points are copied into the Set Angle and Set Length boxes for convenience.  

 

 

This is a great time to use the ‘Zoom Box’ feature previously 

discussed.  

 

https://appdocumentation.cabmastersoftware.com/annotate.html#tape
https://appdocumentation.cabmastersoftware.com/annotate.html#tape
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/view.html#snap-to-grid
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/view.html#snap-to-handle
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/movement.html#set-angle
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/movement.html#set-length
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Step 3 

Since the distance is only 300mm we are going to choose to extend the size of the ‘Wall 1 Door 450’ by 

dragging it to meet the ‘Wall Blind Return Right’. To do this… 

• Turn on the ‘Select’ tool then click on the ‘Wall 1 Door Right 450’ 

• Ensure ‘Align’ and ‘Detect Collisions’ is ON (using right click menu) 

Notice that the cabinet changes to grey and 
handles appear. 

• Select middle handle as per illustration 
and drag to meet the ‘Wall Blind Return 

Right’  

• On the Cabinet Details > General Options 
page, change the Quantity of doors to 2 

 
 

Step 4 

Now we want to place an open wall unit between the ‘Wall Blind Return Right’ and the ‘Tall End 
Panel’ located next to the ‘Tall 2 Door’ – see illustration in Step 5. 

We will need to use the ‘Tape Measure’ to measure the gap.  

• Zoom in so that you can clearly see the external edges of cabinets, for example 400%. 

• Start by hovering over the left edge of the ‘Tall End Panel’ and hold down the left mouse button; 

• Without releasing mouse button, drag the cursor down to end point i.e. the edge of the ‘Wall 

Blind Return Right’ 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Possible Problem 

If you followed previous instructions, you will have zoomed in and measured the distance, which may 

provide you with an incorrect measurement of 600mm. The reason is that the section selected is 
measuring from the panel and the ‘Wall Blind Return Right’.  

It should be measuring between the two panels and the correct measurement is 582mm. 

 

Solution 

In the View > Snapping group, turn ON ‘Snap to Handle’ and select from the Handles drop list 
<all sections> and measure again. Note that on releasing the mouse button at the end point, the 
angle and the distance between the two points are copied into the relevant Movement edit boxes. 
 

 
 

 It is important that after you have completed the measurement, set Handles back to <none>. 

Of course, you could have simply formatted 

the placed cabinet and edited the width at the 
same time as changing the door quantity. 
There are many ways to accomplish the same 
thing. It is all a matter of personal choice! 
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Step 5 

Select a ‘Wall 1 Door’ and... 

• using the Cabinet Tool, change width to 582mm  

• place in previously measured position, as shown. 

 

 

 

 

 

 

 

 

 

 

 

 

At the end of this lesson your drawing should look like the illustration below. 

 

 

This lesson is now completed. Save your drawing. 

 If the cabinet is too big to fit into cavity… 

• Hold ‘Ctrl’ key while dragging cabinet; 

• When in place, let go the left mouse button. 

• Finally, release the ‘Ctrl’ button 
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Lesson 7 – Voids and Dimension Tools 
In this lesson we are going to… 

▪ Add a void from the cabinet library 

▪ Introduce Dimension and DimSet tools  

▪ Add appliance cabinets and pantries 

▪ Radius shelves 

▪ Add an Elevation onto the Plan 

 

Dimension and DimSet Tools 

Dimension tools provide another way that to measure distance either individual items, sections or all 

items included in your drawing.  

DimSet (short for Dimension Sets) are collections of dimension lines where each line can be measuring 
a different part of a drawing and allows you to dimension drawings quickly and effectively.  

You can change the default dimension label to show a different number of decimal places, extra details 
such as mm, colour, font size etc. As shown, you can also turn ON/OFF the display of each Dim Line 
and set the colour etc. (Base Cabinets with one decimal place, Benchtop with two decimal places and 

units, Upper Cabinets in olive green and Overall Wall is brown both with no decimal place). 

Dimensions are associative  

This means dimensions attached to objects in the drawing will resize automatically when the object is 
changed or moved to a different location. Turning on ‘Snap To Handle’ will ensure that the dimensioning 
command tool will know which cabinet handle they are meant to be associated with. 

Moving Dimension lines 

If you want to make dimensions a little cleaner to see and easier to understand, especially around panels 
and items that can get a bit cluttered, you can manually move existing dimensions anywhere you like. 

After dimensioning, simply hold down the 'Ctrl' key and select individual text dimensions and move 
text to a new position of choice.  

In this tutorial we will briefly discuss dimensions and it is advisable to refer to the Application User 
Guide tutorials on… 

• Dimensions  - This tutorial includes a video  and discusses tips and tricks as well as… 

o Auto-Dimension - Note that if you want to dimension Whole Page it is advisable to activate 
very early in your drawing as it works on placing Dim Sets along each wall in the drawing and, 
with complicated drawings, this may take some time. 

o Create and Save your own customised DimSet. 

• Dimensions Angular & Radial  

o Angular Dimensions are used to measure the angles on many different items. 

o Radial Dimensions are used on circle cutouts, benchtops etc 

• Dimension Format Label  

o Discusses how to use the DimSet Tool  to customise and display decimal places and extra 

details such as units, decimals, notations etc.  

https://appdocumentation.cabmastersoftware.com/view.html#snap-to-handle
https://appdocumentation.cabmastersoftware.com/dimensions.html
https://appdocumentation.cabmastersoftware.com/dimensions.html
https://appdocumentation.cabmastersoftware.com/dimensions-angular.html
https://appdocumentation.cabmastersoftware.com/dimensions-angular.html
https://appdocumentation.cabmastersoftware.com/dimensions-format-label.html
https://appdocumentation.cabmastersoftware.com/dimensions-format-label.html
https://appdocumentation.cabmastersoftware.com/dimension-set.html
https://appdocumentation.cabmastersoftware.com/dimension-set.html
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Filling in 45 Degree Angled Corners 

The floor plan has two 45-degree angled sections. We are going to add two voids from the cabinet library 
at 135 degrees. It is therefore important to check the angles. 

 

Step 1 

Select ‘Floor Corner Filler’ from drop list.  
 

Step 2 

On the Cabinet Details > General page 

• Change the Int(ernal) Angle to 135 

degrees. 

 

 

 

Step 3 

Place ‘Floor Corner Filler’ in each of the 45-degree corners on Wall Edge 2 

(which is on the left-hand side), as shown.  

 

Previously we learnt how to place a large cabinet in a small 
space using the ‘AutoCutback’ feature.  

We will now learn how to accurately place a small cabinet into a 
wider gap.  

 

Using Dimension Tools 

For this lesson we will use the ‘Dimension’ tool to calculate the gap between individual cabinets i.e.  
the two filler cabinets we have just placed. 

 

The dimension tool works in a 3 click process.  

After selecting Insert > Dimension tool   

1. The first click defines where you want the measurement to 
start from.  

2. The second click defines where you want to measure to. 

3. The final click will present a dimension line which you then 
drag to place. 

• Note that the direction of measurement of the void i.e. 
1236, is displayed differently to the direction of the wall 

dimension i.e. 1800. See note next page.  

The Dimensions Angular & Radial tutorial  in the Online User Guide shows you how to calculate the 
internal angle for the wall (Edge 2) used in this tutorial. 

You may need to check Align is on and use the + or – keys 
to rotate. 

There is no need to change settings in the Cabinet Tool for 

the second placement or use ‘Select Into’ feature 
discussed previously in Lesson 6. 

 

This tool is useful because often it is an advantage to see all the dimensions while working on your 

drawing. Remember to ensure that Insert > Snap to Handle is turned ON. 

 

https://appdocumentation.cabmastersoftware.com/dimensions-angular.html
https://appdocumentation.cabmastersoftware.com/dimensions-angular.html
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Placement between Voids 

Now that we have been able to accurately establish the distance 
between the two voids, we can now add a cabinet. 

From the cabinet drop down list, select a ‘Floor 2 Door’ and 

using the Cabinet Tool…  

• Amend the width to 1236mm 

• Place cabinet on drawing.  

 

 

 

 

 

 

 

Place Dishwasher and Fridge Cabinets 

Now we are going to place a series of cabinets around the remainder of the exposed walls.  

Cabinet 1  

Select a ‘Floor Dishwasher’ and  

• place to right of top ‘Floor Corner Filler’ cabinet.  

• The Dishwasher module already has allowances for a gap 
between dishwasher and adjoining cabinets. 

Direction of Measurement depends on the direction of the line 

you click along.  Compare the dimension line shown here  →        
to the one on the previous page. Note the start point is different. 
 

Dimension Tool used to change the style and colour of the lines 
for individual items is different to the tool used for Dimension 
Sets i.e. a collection of lines used to illustrate the placement of 

dishwasher etc discussed next. See Dimension Tool  

Remove Dimension Lines by turning on Select then…  

• Move mouse over the lines to remove until handles appear. 

• Left click to select the dimension line (which now should appear 
greyed out) 

• Now simply use the delete keyboard key or ‘Clear’ from the 
right click menu. 

Remember, if you are having difficulty placing, 

right click on the cabinet and turn ON Align and 

turn OFF Detect Collisions. 

See illustration next page for placement of the numbered cabinets. 

Note also that we have added a  by clicking on the   
command icon, then clicked on the left end of the wall (Edge 3) 

and then the right end of the same wall (Edge 3). The diagram 

has dimension lines displayed for Base Cabinet (in red), Upper 
Cabinets (olive green) and the Overall Wall (brown) with Benchtop 
turned OFF i.e. not displayed, set in the DimSet Tool   

 

https://appdocumentation.cabmastersoftware.com/dimension2.html
https://appdocumentation.cabmastersoftware.com/dimension2.html
https://appdocumentation.cabmastersoftware.com/dimension-set.html
https://appdocumentation.cabmastersoftware.com/dimension-set.html
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Cabinet 2  

Place ‘Floor 4 Drawer’  

• Ensure it has a width of 450mm and place to right of 
Dishwasher (i.e. cabinet 1).  

Cabinet 3 

Place a ‘Floor 1 Door’ width 450mm right of Cabinet 2.  

 

 

 

Cabinet 4 

Select and place a ‘Tall End Panel to Floor’ to the right of 
Cabinet 3. 

 

Cabinet 5 

Select and place a 2 door ‘Wall Fridge Cab’ (default width 

740mm) to the right of Cabinet 4 (Panel). 

 

 
Cabinet 6 

Place ‘Tall End Panel to Floor’ to the right of ‘Wall Fridge 

Cab’ (Cabinet 5).  

 

 

The placement and dimension lines should look similar to the following on Wall Edge 3.  

 

  

We are now going to place a Fridge Cabinet but before we do this, we need to place a tall end panel 
directly after the ‘Floor 1 Door 450’ just placed as this will have an exposed end above the benchtop. 

 

Since there is a doorway to the right of the fridge cabinet, we will need to ensure that the Fridge 

Cabinet is sealed. 

Note that the Door Swing has been turned on again and the colour has been changed to red. 
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Radius Open Shelf End Cabinets 

We are now going to finish off the cabinet placement on this wall (Edge 3) by placing wall cabinets above. 

Wall Cabinet 1 

Select ‘Wall 2 Door’ (default 750mm) and on the… 

Cabinet Details > Options page 

• Enable ‘Right’ Insertion Point under Misc options 

• Place to the left of the ‘Wall Fridge Cab’ 
 

Wall Cabinet 2                                         

Select ‘Wall Open Left’ and on the… 

Cabinet Details > General Settings page 

• Edit the width to 300mm  
 

Cabinet Details > Options page 

• Tick ‘Apply Radius’ to round corners  

• Place to left of ‘Wall 2 Door’ just placed 

 Wall Open Cabinet 

• Right click on the placed cabinet, lesson 1 shown right, and select Format menu option. 

• On the Options page, tick the ‘Apply Radius’ as per illustration above.  

In Lesson 1, we placed a ‘Wall Open Left’ as illustrated below right, which does not have rounded 

shelves. To be consistent with the wall cabinet just placed, we need to round the shelves.  

 

Insertion Point 

The Insertion Point on the Options page determines the fixed side from which a cabinet will 

extend/contract if its width is changed. For example, here is a 1000mm wide Cabinet in front of a 
Wall (for reference) with the Insertion Point set to the Left (LHS)...  

(1) When we increase the WIDTH - it extends to the right (because its fixed side is the Left).  

(2) Repeating this with the Insertion Point set to be the Right (RHS), the opposite occurs... 
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3D Hidden View 

The 3D view is a good checking 

point where you can review your 

drawing and pick up on missing 

end panels or, as in this case, 

different shelf profiles. 

 

 

 

 

 

Place Pantry Cabinets 

Now we will add cabinets to the left of the bottom ‘Floor Corner Filler’ on Wall Edge 1. 

See illustration for placement of numbered cabinets. 
 

Cabinet 1 

Place a ‘Floor 1 Door Left’ (default width 450mm) to left of the 
bottom ‘Floor Corner Filler’.  

 
Cabinet 2 

Select and place another 
‘Tall End Panel to Floor’ 
to left of Cabinet 1. 

 

Cabinet 3 

Select a ‘Tall Micro Pantry 
Drawer’ width 700mm and 
place left of Cabinet 2 
(Panel).  

 

Cabinet 4 

Select a ‘Tall Sliding 
Pantry Left’ width 

1190mm and place to left of 

Cabinet 3.  

 

Cabinet 5 

Finally place a ‘Wall 1 Door 

Left’ width 600mm over 
Cabinet 1, as shown.  

Note wall dimensions are displayed separately to floor cabinets. 

 

At the end of lesson 7 your drawing should look similar to the image on the next page.  

Since we are going to place a Wall Oven with microwave next to this, we need to seal with more ‘Tall 
End Panels’ 
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You have completed this lesson. 

Elevations on Plan 

In this image, an elevation of the cabinets placed on Wall Edge 1 has been added.  

Elevation views are automatically created along each wall in a drawing. To place on plan… 

• select the wall you want to place on the plan using the drop list (or blue navigation arrows).  

o A red line is displayed to indicate your selection.  

• Next click on the 'Place Elevation' command icon and then click a point on the drawing 
which will add the elevation onto the plan. 

Elevations can also be Formatted just like any drawing tool i.e. you can resize and change the style 
of the presented elevation e.g. the example below has the ‘Aggregate dims’ disabled and therefore 

shows total length and has been resized to 75%. 

Note that Manual Elevation lines can be also be created for individual cabinet/s.  

For a full discussion see the Elevations Tutorial  in the Online User Guide. 

 

https://appdocumentation.cabmastersoftware.com/elevations.html
https://appdocumentation.cabmastersoftware.com/elevations.html
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Lesson 8: Island Bench and Rotation  
In this lesson we are going to: 

▪ Create an Island Bench and add a benchtop overhang. 

▪ Rotate multiple cabinets 

 

Creating the Island Bench 

To start the process, we are going to select the four cabinets that we want to work with and then place 

and join them on the drawing.  

The overall position of the cabinet is not that important 
at this stage. We will move it into the desired position 

after we have completed the construction. The final 
position of the Island Bench will be adjacent to the 
‘Floor Standard 1200’ already on the drawing. 

Step 1 

Select a ‘Floor 3 Drawer’ and on the Cabinet Details > 
General Settings page… 

• Change the Depth to 448mm 

• Default ‘Width’ should be 600mm 

• Place on drawing using the image for reference. 
 

Step 2 

Now you can place another 3 of the same cabinet into the 

shape of an Island Bench as shown → 

 

 

 

 

 

 

 

Once you have placed the four cabinets into the shape of an Island Bench, your drawing should look 
similar to the illustration. Later in this lesson, we will rotate the island bench. 
 

Step 3 

We are now going to finish the Island Bench by sealing the ends 
with end panels, sealing the benchtop and creating overhangs. 

Finally, we will move the bench into position. 

Before placing the end panels, we must know how wide they need 
to be. To do this we will use the Tape Measure tool. 

• First turn ON the Snap to Handle <all sections> →    

 

  

 

 If you have trouble joining the four 
cabinets together, you may wish to right 
click on Cabinet Tool and turn the 

‘Align’ option OFF (shown here as ‘On’)  

 

Remember to ‘Select’ each cabinet and keep the left mouse 
button depressed while you rotate using + or – keys. For 

smaller increments, hold down ‘Ctrl’ key while using + or – 

 

 

 Remember to turn this off by changing to <none> 
after you have completed the measuring. 

Handle Section drop list is also available on the Plan                             
View Options [F9]  on the Visibilities page. 

 

 

 

For more on Benchtops  see the CM-Cabinets Library User Guide. 

https://appdocumentation.cabmastersoftware.com/view-options.html
https://appdocumentation.cabmastersoftware.com/view-options.html
https://documentation.cabmastersoftware.com/Benchtops.html
https://documentation.cabmastersoftware.com/Benchtops.html
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Zoom in close for this measurement, as there are 

a number of snapping points.  

Since we want the panel to extend to the end of 
the drawers, the dimension required is the one 
stated on the right i.e. 936mm = 448mm depth 
of cabinet plus 18mm drawer plus 2mm gap x2.  

 

Step 4 

Select ‘Floor End Panel to Floor’ and on the… 

• Panel Details > General page  

• Uncheck ‘Flush with Doors’ to override 
of Depth default (normally greyed out) 

• Change ‘Depth’ to 936mm 
 

• Panel Details > Benchtop page 

• Untick ‘Include Benchtop’  

 

 

 

 

• Place an End Panel on each end.  

(The placed Panels have been highlighted in yellow). 

 

 

Add an Overhang 

To Seal and create an Overhang, double click on 
placed cabinets to open the cabinet properties 
and on the Cabinet Details > Benchtop page… 

Cabinet 1 and 2 

• Tick the Left Seal checkbox 

• Enter a 50mm overhang 

Cabinet 3 and 4 

• Tick the Right Seal check box 

• Enter a 50mm Overhang   

Now we will select each placed cabinet and modify (format) as per following instructions to create an 

overhang and seal the edges of the benchtops. 

To help you understand the following method see the numbered diagram. 

 

Turn off Handles i.e. change to <none> 

 

When you have completed these 

steps, the Island Bench should look 
the same as the illustration. Note 
that we have used the Tape 
Measure with Snap to Benchtop. 
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Rotate Island Bench 

Turn on Select  and … 

• click and hold down the left mouse button on blank area of page close to the cabinets that you 

want to select.  

• ‘Drag and release’ to form a rectangle (see notification area of the status bar for instructions).  

Here we have dragged from top left clockwise to bottom right but it doesn’t matter where you 
start. Leave as much space as you can without touching objects that you don’t want to move.  

The object should have changed colour and the handles should be obvious. 

We are now ready to rotate the cabinets as a single entity.  

• Use the + or – keys to rotate the cabinet so that it is the same angle as the ‘Floor 2 Door’ on 
Wall Edge 2.  

Remember, using the ‘Ctrl’ key with the + or – key rotates by smaller increments. 

 

 

 

Your drawing should look similar to the above image. 

You have completed this lesson.  

As discussed in Lesson 1, when Select  is turned 
ON, it changes to the Select tool. 

This allows you to highlight objects by clicking on 
them individually or select multiple items by 
clicking on a blank area of the drawing near items 
for selection and dragging the mouse to form a 

rectangle.  

Any objects inside or touching the rectangle will 
become selected, shown by the colour changing 

and handles (small squares) being presented. 

https://appdocumentation.cabmastersoftware.com/select.html
https://appdocumentation.cabmastersoftware.com/select.html
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Extra Notes  

End Panel Benchtop Radius 

You can radius the end of the benchtop section of end panels rather than have to add a separate piece 

of benchtop. If the chosen radius is less 

than the minimum possible radius for the 

depth of the benchtop, then it will 

automatically default to the minimum 

value. 

Whether the radiused side of the 

benchtop is on the left or right is 

determined by the ‘Left/Right’ radio 

buttons as illustrated.  

To see the radius on the plan, the 

benchtop end needs to be ‘sealed’, this is 

done using the ‘seal’ checkboxes that 

corresponds with the orientation. 

 

Arrange  

In plan view, objects are displayed on the drawing in the order in which you placed them. This may lead 
to some objects overlapping or completely obscuring others. However, you can reset this using the 
‘Arrange’ commands on the Insert tab. 

 

Bring to Front 

To make an object completely visible, select it then use the ‘Bring to Front’ 
command.  

Bring Forward  

Takes the currently selected object and brings it forward one step. If objects 
placed on top of one another are considered to be in a stack, this moves the 

selected object one place up the stack. To move the object all the way to the 
top of the stack, use the ‘Bring To Front’ command.  

Send To Back 

Similar to the ‘Bring To Front’ command, except it places the selected object 

behind any others. For example, a floor would normally be sent to the back.  

Send Backward   

Takes the currently selected object and moves it down the stack by one position. 
To move the object all the way to the bottom of the stack, use the ‘Send To Back’ 
command. 

The radius options on the End Panels are not as comprehensive as the separate benchtop unit. For 
example, it is not possible to specify an overhang and have the system calculate the radius for you. 

 

You can also select the object in Plan View and use the right click menu ‘Order’ options. 

mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/format.html#bring-to-front
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/format.html#bring-to-front
mk:@MSITStore:C:/AllMasterSoftware/CabMasterPro/CabMasterPro.chm::/menus-and-toolbars/menus/format.html#send-to-back
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Lesson 9:  Accessories, Doors and Windows 
In this lesson we are going to: 

▪ Add a hotplate, range hood, entry door, sink from a different library i.e. CM-Accessories 

▪ Add a floor 

▪ Introduce the ‘Marker’ tool and other tools to help arrange objects on the drawing 

▪ Swap libraries to obtain other cabinets or items e.g. the cooktop and door 

 

Placing the Cooktop and Range Hood 

We are going to place a hotplate on the Island Bench that we created in the previous lesson. We will also 
place a range hood above the hotplate.  

The cooktop and rangehood are located in a different library to 

cabinets, so you need to select the CM- Accessories library using 
the drop menu. Then… 

• Select a ‘Cooktop’ and place in the centre of the Island Bench. 

• Rotate to align. 

 

 

 

 

 

Now we will place a rangehood over the cooktop. 

• Select the ‘RH- Island’ from Cabinet drop list.  

• Place Range Hood over the ‘Cooktop’ and rotate to align. 

 

 

 

 

 

  

To enable the cooktop is visible on the Island in 3D view the Height 
off floor is automatically set to a height greater than that of a 
standard cabinet but you can add more if required. 

The properties page also allows you to select how you want to view 
a selected picture (shown here SMEG) or model.  
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Marker Tool  

In this lesson we are going to place a door and use the Marker tool on the Insert tab  as it enables 
you to set up accurate measurements.  

The Marker tool provides a snap handle to assist in the easy placement of objects especially if you need 

to set out some geometry on screen for the placement of walls, cabinets, or Paper Space objects.  

 

Uses of markers include: 

▪ Leaving a gap in the wall to represent a doorway.  

▪ Placing a cabinet a fixed distance from the end of the wall.  

▪ Defining a bay window.  

To ‘Clear All Markers’ use the right click menu option, shown. This deletes all marker objects from all 
pages in your drawing. 

 

Horizontal Panel 

The Horizontal Panel tool (or HPanel) allows you to place horizontal sections that may form unusual 

shapes, which can represent, for example, a benchtop inside a bay window, shelves, bulkheads such as 
the one on the cover of this manual.  

You will usually want either ‘Snap to Handle’ or ‘Grid’ turned ON while drawing HPanels.  

To place a panel, simply select the icon and click the corner points on the plan view. If you cross over or 

just incorrectly position any vertices, you can always drag them around after placement. 

Now we are going to position the door 1100mm from the right wall and against the back wall. 

 

Placing the Door 

To place an entry door, we do exactly the same as placing any other cabinet from the library i.e.              
(1) select, (2) customise if required, (3) place it on drawing.  

However, we need to be more accurate with our measurements when 
placing entry doors. This is where the ‘Marker’ tool is useful.  
 

Using Markers to Create Doorway 

We are going to place the door 1000mm from the corner where 
the ‘Floor Angled 900’ is placed. Ensure that ‘Snap to Handle’ is 

ON. Then… 

• Turn on the Marker tool and place the 1st Marker close to 
the back right-hand corner of the ‘Wall Angled’ as shown, by 

left clicking mouse when you are in position;  

Using the ‘Snap to Handle’ means you don’t have to be exactly 
on the back corner; 

• To place 2nd Marker, enter 1000mm in the ‘Set Length’ 
edit box; 

• Then click the  left arrow key. 
 

You should now see a second marker placed 1000mm to the left of the first marker as per the illustration.  

https://appdocumentation.cabmastersoftware.com/insert.html
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Place Door in Doorway 

Now that your markers have been placed, we can select a door 
from either the CM-Accessories or the CM-Cabinets library:  

• Place the door so that the right handle section of the door 
snaps to the 2nd Marker, shown below.  

 

 

 

Door Architraves Only Option 

There is also the ability to have just the Architraves showing on an entry Door.  

 

   

 

 

 

 

 

Architectural view 

If not visible then you can use the right click menu or the commands on the Insert tab. 
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Adding a Window and Sink 

To add windows, it is again best to use markers. (Snap to Handle should still be turned ON). 

We want our window to be located 200mm from the corner of Wall Edge 2 and its width is 1400mm. 
 

Use Markers to Position Window 

To do this: 

• Click on the Insert > Marker tool to turn on; 

• Place the 1st Marker on the back corner of the 
‘Floor Corner Filler’, as shown below. 

• To place the 2nd Marker type in the ‘Set Angle’ 

box 225 degrees and in the ‘Set Length’ box 
200mm and click on the ‘At Angle’ icon → 

This will place the second marker 200mm at an 

angle of 225 degrees to the first marker. [Markers have been highlighted in green to show position] 

 

Place Window 

• Select ‘Window’ from the CM-Accessories or CM-Cabinets 
library; 

• Customise before placement by using Cabinet Tool and 
change ‘Width’ to 1400mm. 

 

• Place the window over the ‘Floor 2 Door’ with the insertion point to the left of the 2nd marker.   

Zoom in to do this.  

This is the window shown in 3D View. There are 

a number of options available to customise the 
window, including the scenery that can be 
displayed. 
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Using ‘Move in 3D’ option 

There are multiple ways of achieving the same result. Another way to place the window without using 
Markers is to use the ‘Move in 3D’  command from the right click menu.  

To use this method: 

• Place the window in the corner of the two walls (i.e. Wall Edge 2 and Wall Edge 3) 

• Right click on the window and from the presented menu, select ‘Move in 3D’ 

• This presents a dialog allowing you to enter in the direction and the measurement. 

• Enter in 200mm and select Left from the drop list, as shown. 

• Click OK to activate and close dialog.                                                    

 

 

 

 

 

 

Adding a Sink 

Now select a sink and place it under the window. 

• Select ‘Sink’ from CM-Accessories library 

• Place sink as shown  

The Snap to Handle will still be on. If you 
have difficulty placing toggle the ‘Align’ and 
‘Detect Collisions’ options. 

  

https://appdocumentation.cabmastersoftware.com/move-3d.html
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Adding the Floor 

We are now ready to add the floor. The simplest way is to use the Floor icon on the Insert tab. Simply… 

• Click on the Floor icon 

• Then click each corner of the wall until complete.  

NB: In the diagram green  squares have been added to illustrate each corner where we clicked 
but note that no such markers will be presented until the completed floor is selected.  

 

Floor in 3D View 

The floor image can be controlled using the Floors property sheet as shown. 
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Another way to place a Floor is by using the one in the CM-Accessories library but you would first 
need to measure the widest space of the room with the ‘Tape 

Measure’.  

• Customise the Floor by changing the ‘Width’ to 5773mm 
and ‘Depth’ to 3900mm 

If you right click on the Cabinet Tool, you should find that 
the Detect Collisions has been automatically turned off. 

• Place the ‘Floor’ on the drawing as per illustration below. 

 

You have completed this tutorial. 

 

CabMaster™ has many other features such as:  

• Model images in Plan and Elevation views 

• Angle Ceilings 

• Arch Profile, X Shape Profile and Glass Panes on Doors 

• Tables for drawer runners, handles, hinges and materials are available for download 

• See discussion and video on how to download from our StoreMaster website. 

• Walkthroughs 

And much more! Watch the quick video  (0:48mins)  

 

Reporting, Pricing and Machining 

Reporting 

There are two key reporting types within CabMaster™ that are easily customised by the user in the 
Catalog/Drawing Properties. See Online User Guide  

1. Commercial reports such as quotations, invoices etc 

2. Manufacturing reports such as cutting lists, assembly details, etc 
 

Pricing 

There are many pricing options within the CabMaster™ library providing a tremendous amount of 
flexibility. At the highest level, all cabinets have the capacity to contain a price. At a very simple level 
the price could be a fixed cabinet price. See A Guide to the Best Pricing Option for your Business.   

There are a number of videos available and are being constantly added to on the CabMaster Website 

https://documentation.cabmastersoftware.com/StoreMaster.html
https://www.youtube.com/watch?v=X5JlF2C93XU
https://documentation.cabmastersoftware.com/Reports.html
https://documentation.cabmastersoftware.com/Pricing%20Overview.html
https://cabmastersoftware.com/more-info/videos/
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Machining 

With CabMasterPro™ and higher software machining is available. 

Panel Estimator 

Panel Estimator  allows you to produce efficient cutting or pressing patterns, it can tell you the best 
way to arrange boards to produce the most optimal patterns with the least amount of wastage. It is not 
tied to a particular brand of saw, it will just as easily optimise for a bench saw, laminate press or manual 
cutting. 

EzyNest/EnRoute 

If you are using nested based manufacturing, it integrates seamlessly into EzyNest or EnRoute, which 
optimises the cabinets onto sheets ready for production.  

CabMaster™ allows you to export machining files (DXF files) which contain information for each 
component in the current drawing configured to output machining data. See discussion and video  

See also the Machining topic in the Online User Guide  

 

 

 

https://appdocumentation.cabmastersoftware.com/panelestimator.html
https://appdocumentation.cabmastersoftware.com/machining-view-current.html
https://appdocumentation.cabmastersoftware.com/index22.html

